Saving a new candidate

Tagged:

Currently contains 8 posts

Avatar

August 27, 2021 16:47

tandem

Hello,
We’re using the API to save a new candidate to PCR…it was all working fine until a couple of weeks ago. For some reason the CompanyName is not attaching to the registration (its name, mail and other data it’s saved correctly). Also PCR is leaving its ID blank (it’s supposed to be generated automatically, right?).
We’re using this to set the CompanyName:
CompanyName = “Candidatos*”;

Does the field changed its name or something? We don’t get why it was working and without modifying the code, suddenly it’s not.

Avatar

August 30, 2021 14:15

tandem

Hello again…Could you please help me with this issue? Thanks in advance.

Avatar

September 07, 2021 13:15

Jarrid-PCRecruiter

Sorry for the delayed response. Does it work if you exclude special characters from the company name? If not, what’s the code/query you’re running?

Avatar

September 07, 2021 16:46

tandem

Let me check, thank you

Avatar

September 14, 2021 21:19

tandem

Thanks…it worked! When a new candidate applies to a position it works fine… But when the same candidate applies to a new position (when its data needs to be updated), it does the same again: it erases the UserID and the username (which previously it was “APIUser”)

Avatar

September 28, 2021 16:02

Jarrid-PCRecruiter

What does it erase it with?

Avatar

September 30, 2021 23:48

tandem

It leaves the field empty. The space is blank.

Avatar

October 01, 2021 02:52

Jarrid-PCRecruiter

It sounds like you may need to specify the username as part of the POST/PUT. Does it work if you do that? If not, can you send me the contents of the JSON/payload you’re posting?

jarrid (at) mainsequence (dot) net

Reply to thread